티스토리 뷰

컴퓨터 이야기/Python이야기

Centos6에 파이썬3을 설치한 이야기...

유유 자적한 삶을 위하여 code_control 2017.12.18 21:49

크게 쓸 내용은 없지만 또 남겨본다.

리눅스계열 혹은 맥은 기본적으로 파이썬2 버전이 설치되어있다.

이번에 3버전으로 넘어가면서 CentOS에도(이하 리눅스) 설치를 하였다.

리눅스는 뭐 항상 기본적으로 ./Configure make make install 해주면되는데!!!

이러고 곱게 끝나면 우리 리눅스가 아니지..

다와서 에러 메세지를 띄웠다.(파이썬3 실행엔 지장이 없는 에러지만)

다들 잘가다 에러 하나 띄워지면 무지 거슬릴것이라 생각된다.

[zipimport.ZipImportError: can't decompress data; zlib not available]

에러 내용은 대충 zipimport 안되고 압축풀기 불가인듯 하다. 그냥 단어 직역했다.


우선 zip import가 안되니 관련 Lib를 설치후 다시 make install해주니 pip-9.0.1과 setuptools-28.8.0이 정상적으로 설치 되었다.

아마도 저 에러가 발생하면서 두 패키지를 설치하지 못한듯 하다.


아! 관련파일은 yum -y install zlib-devel 해주면 된다 끝.

댓글
댓글쓰기 폼